Cách khắc phục tình trạng không cho cập nhật hay cài đặt plugin mới trên WordPress

Hôm nay giải quyết một task do một cậu đồng nghiệp chuyển qua. Task này là yêu cầu kiểm tra khắc phục tình trạng không thể cập nhật mới plugin đã cài đặt trên hệ thống. Mỗi khi cập nhật mới thì sẽ có thông báo: Could not remove the old plugin.

could-not-remove-the-old-plugin

Nếu là người có kinh nghiệm thì hiểu ngay vấn đề đây không phải lỗi của hệ thống mà do quyền thiếp lập ghi cho thư mục bị hạn chế. Và để giải quyết là chỉ cần xét lại quyền cho phép ghi là được. Cách đơn giản là truy cập vào vùng lưu trữ bằng giao thức FTP và chỉnh CMOD thành 755 hoặc 777 là được.

Các thư mục cần kiểm tra quyền là wp-content, themes, plugins, uploads. Đây là các thư mục gốc nếu xét quyền vẫn không được thì kiểm tra lại thư mục của plugin hay theme đó.

Chúc các bạn thành công.

Huỳnh Mai Anh Kiệt

Cảm ơn bạn đã đánh giá! Bạn có thể chia sẻ cảm nhận bài viết này lên các mạng xã hội: hoặc .
Bạn cảm thấy thế nào về bài viết này?
  • Vui mừng
  • Hấp dẫn
  • Thú vị
  • Chán
  • Buồn
  • Tức giận

Huỳnh Mai Anh Kiệt

Anh là một người đam mê công nghệ. Hiện tại anh là một lập trình viên tại Quy Nhơn.

leave a comment

Create Account



Log In Your Account